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Microsoft Draw Overview

Microsoft Draw is a drawing application that you use from within other Windows applications.    The application from 
which you invoke Microsoft Draw is called a destination application. Follow the instructions within the destination
application to open Microsoft Draw.    You can use Microsoft Draw to create and edit new drawings, clip art, or 
drawings imported from other applications.    Drawings are displayed in Microsoft Draw’s standard 22 x 22-inch 
drawing area with Microsoft Draw’s Toolbox ready for you to use.    

Related information
       Using Microsoft Draw's Toolbox  
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Overview

Microsoft Draw's Toolbox contains nine drawing tools.    To choose a tool, click the tool you want.    In the drawing 
area, the pointer changes to represent the selected tool.    

Related information
       Enhancing objects  
       Editing objects  
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 Arrow
Use the Arrow for manipulating and selecting objects and groups of objects.    Drag the mouse to move selected 
objects or drag a resize handle to reshape them.    To select multiple objects, draw a bounding box around them. 
When you choose the Arrow tool, any previous selection in the Toolbox is cancelled.    

Related information
       Selecting objects         Moving objects  
       Editing objects  
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 Zoom In/Zoom Out
Use the Zoom In/Zoom Out tool to change the magnification of your drawing.    You can also use the View menu to 
choose one of the seven levels of magnification: 25%, 50%, 75%, Full Size, 200%, 400%, or 800%.    Use any of the 
tools in the Toolbox while at different levels of magnification to manipulate and change a drawing as desired.

Note that when a drawing is placed into the destination application, it is updated in full (or normal) view, and not
the magnified view.
How to

       Use the Zoom In/Zoom Out tool  



To use the Zoom In/Zoom Out tool 
1 In the Toolbox, click the Zoom In/Zoom Out tool.    
2 Position the mouse pointer on your drawing where you want to zoom in or out.

The pointer changes to a magnifying glass ( ).    
3 To zoom in (increase magnification one level), click the mouse button.    

To zoom out (reduce magnification one level), press the SHIFT key as you click.    
Each click of the mouse button increases or reduces the magnification one level.    The area where you click

the mouse button is centered in the window.    
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 Line
Use the Line tool to draw straight vertical, horizontal, or diagonal lines.    

How to
       Use the Line tool  



To use the Line tool
1 In the Toolbox, click the Line tool.    
2 Position the pointer where you want the line to start.    
3 Hold down the mouse button and drag to draw a line.    
4 Release the mouse button to complete the line.    

To draw a line from its center point, press the CTRL key and hold it down as you drag.    
To constrain a line to the nearest 45° angle (0°, 45°, 90°, 135°, and so forth), press the SHIFT key and hold 

it down as you drag.    
To draw a line from its center point as you constrain it to the nearest 45° angle, press CTRL+SHIFT and hold 

them down as you drag.    
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 Ellipse/Circle
Use the Ellipse/Circle tool to draw ellipses and circles.    

How to
       Use the Ellipse/Circle tool  



To use the Ellipse/Circle tool
1 In the Toolbox, click the Ellipse/Circle tool.    
2 Position the pointer at one corner of an imaginary box that will surround the figure you want to draw.    
3 Hold down the mouse button and drag to draw an ellipse.    
4 Release the mouse button to complete the ellipse.    

To draw an ellipse from its center, press the CTRL key and hold it down as you drag.    
To draw a circle, press the SHIFT key and hold it down as you drag.    
To draw a circle from its center, press CTRL+SHIFT and hold them down as you drag.    
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 Rounded Rectangle/Square
Use the Rounded Rectangle/Square tool to draw rectangles and squares with rounded corners.    

How to
       Use the Rounded Rectangle/Square  



To use the Rounded Rectangle/Square tool
1 In the Toolbox, click the Rounded Rectangle/Square tool.    
2 Position the pointer where you want one corner of the rounded rectangle to start.    
3 Hold down the mouse button and drag a rectangle.    
4 Release the mouse button to complete the rounded rectangle.    

To draw a rounded rectangle from its center, press the CTRL key and hold it down as you drag.    
To draw a square with rounded corners, press the SHIFT key and hold it down as you drag.    
To draw a rounded square from its center, press CTRL+SHIFT and hold them down as you drag.    
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 Rectangle/Square
Use the Rectangle/Square tool to draw rectangles and squares.    

How to
       Use the Rectangle/Square tool  



To use the Rectangle/Square tool
1 In the Toolbox, click on the Rectangle/Square tool.    
2 Position the pointer at one corner of the rectangle that you want to draw.    
3 Hold down the mouse button and drag a rectangle.    
4 Release the mouse button to complete the rectangle.

To draw a rectangle from its center rather than from a corner, press the CTRL key and hold it down as you 
drag.

To draw a square, press the SHIFT key and hold it down as you drag.    
To draw a square from its center, press CTRL+SHIFT and hold them down as you drag.    
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 Arc
Use the Arc tool to draw arcs that are 90° segments (quadrants) of ellipses.    A filled arc has a wedge shape.    

How to
       Use the Arc tool  
       Edit freeforms and arcs  



To use the Arc tool
1 In the Toolbox, click the Arc tool.    
2 Position the pointer where you want to the arc to start.    
3 Hold down the mouse button and drag the arc.    

The direction in which you drag determines which quadrant of an ellipse you draw (upper left, lower right, and so
forth).    

4 Release the mouse button to complete the arc.    

To draw an arc that is part of a circle, hold down the SHIFT key as you drag.    
To change an arc angle (that is, to make an arc that is more or less than 90° of an ellipse) select the arc, 

then choose Edit Arc on the Edit menu.    



To edit the shape of a freeform or arc
1 Select the object you want to edit and choose Edit Freeform or Edit Arc from the Edit menu.

--Or--
Double-click the object.
Control handles are displayed at the vertices.    

2 Drag the control handles to reshape the figure.    
3 To stop editing a freeform or arc, press ENTER, ESC, double-click the figure, or click outside the drawing area.

To add or delete a control handle on a freeform or arc
1 Select the object on which you would like to add or delete a handle.
2 Choose Edit Freeform from the Edit menu to show existing control handles.
3 Press the CTRL key as you click the edge of the figure where you want the new handle.    

4 Drag the new handle to reshape the figure as desired.
5 To delete a control handle from a freeform or arc, press CTRL+SHIFT as you click the handle you want to delete.    

To remove the last vertex from a figure before you complete it, make sure the mouse button is released 
and then press BACKSPACE.    Continue pressing BACKSPACE to remove consecutive vertices.    

To constrain the movement of the control handle to horizontal, vertical, or 45°, press the SHIFT key as you 
drag the handle.    

As you drag an arc's control handles, the shape of the ellipse on which the arc is based does not change.    
To change the shape of the ellipse, drag the arc's resize handles.    
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 Freeform
Use the Freeform tool to draw closed or open polygon freeforms, freehand freeforms, or combination freeforms.    
Click to add straight sections; drag to add freehand sections.

How To
       Draw a polygon freeform         Draw a freehand freeform  
       Edit freeforms and arcs  

Related information
       Enhancing objects         Editing objects  



To draw a polygon freeform
1 In the Toolbox, click the Freeform tool.
2 Position the pointer where you want the figure to start and click the mouse button.
3 Move the pointer to where you want the first line segment to end and the second line segment to begin and click

the mouse button.
4 Continue to move the pointer and click to draw connected lines.
5 For a closed polygon, click near the beginning of the first line.

Microsoft Draw draws a straight line from the last point in the figure to the first point.
For an open polygon, press ENTER, ESC, click outside the drawing area, or double-click to complete the figure.

To draw a combination figure (with straight and freehand sections in the same figure), alternate between clicking
and dragging.    



To draw a freehand freeform
1 In the Toolbox, click the Freeform tool.    
2 Position the pointer where you want the figure to start and hold down the mouse button.    

After a brief pause, the pointer changes to a pencil.    
3 While holding the mouse button down, drag the pointer to draw the freehand freeform.    

As you draw, Microsoft Draw adds vertices to the figure.    

4 For a closed figure, click near the beginning of the figure.    
Microsoft Draw draws a straight line from the last point in the figure to the first.    
For an open figure, double-click or press ENTER, ESC, or click outside the drawing area.    

To draw a combination figure (with straight and freehand curves in the same figure), alternate between clicking 
and dragging.
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 Text
Use the Text tool to add a text object to your drawings.    

How to
       Use the Text tool  



To use the Text tool
1 Make sure the current settings for font, font size, font style, alignment, and text color are appropriate for the text

you want to type.    You can change them later if you wish.    
2 In the Toolbox, click the Text tool.    
3 Click where you want the text to start.    

A text insertion point is displayed.    
4 Enter the text.    You can type only a single line of text.    

Use the BACKSPACE key, mouse, or arrow keys to correct typing.    
Press CTRL+INS to copy selected characters to the Clipboard.    
Press SHIFT+INS to paste characters from the Clipboard into the text object.    
Press SHIFT+DEL to cut selected characters and place them on the Clipboard.    

5 When you are satisfied with the text, press ENTER, ESC, or click outside the text object.    
Handles are displayed around the new text object to show that it is selected.    

You can change the text color of a completed text object with the Color Palette.    
You can change the text style, alignment, font, or font size of a completed text object with commands from

the Text menu.    
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Overview

Before you can edit, move, or resize an object, you must first select it.    A selected object has resize handles 
which you use to change its size.    

How To
       Select a single object  
       Select multiple objects  
       Select all objects in the drawing  
       Cancel a selection  

Related information
       Enhancing objects  



To select a single object
1 In the Toolbox, click the Arrow tool.    
2 Select an object by clicking anywhere on the drawn part of the object (clicking the interior of an unfilled object 

will not select it).
--Or--
Position the pointer away from any object and drag a bounding box (also called a marquee) to completely 
enclose the object you want to select.    
Note that if you click an object, you cancel any previous selections. 



To select multiple objects
1 In the Toolbox, click the Arrow tool.    
2 Drag the bounding box completely around the objects you want to select.    

Note that when you create a multiple selection, the attributes of all the selected objects are changed as a 
unit.    Specifically, you can cut, copy, clear, and move all the selected objects at once.    You can also change the 
fill color, line color, pattern, line style, and text attributes of the selected objects.    You can also group objects in 
a multiple selection. 

To add to a selection of one or more objects, hold down the SHIFT key as you select additional objects either by 
clicking them or by dragging a bounding box around them.    



To select all objects in the drawing
To select all of the objects in your drawing, choose Select All from the Edit menu.
--Or--
Press CTRL+A.



To cancel a selection
To cancel the selection of a single object or to cancel a multiple selection, click the Arrow tool or click away 
from the selection.    
To cancel the selection of a single object or a multiple selection, hold down the SHIFT key as you click anywhere 
on the drawn part of the object.    
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Working with object groups

Grouped objects are objects that have been combined so that they can be treated as a single object (moved, 
resized, rotated, flipped, colored).    When you group objects, you can change their attributes just as if the objects 
were a multiple selection; you can cut, copy, clear, and drag the grouped objects and you can change their fill 
color, line color, pattern, line style, and text attributes.    In addition, you can resize, flip, and rotate a group as if it 
were a single object. 

How to
       Group objects         Ungroup objects  

Related information
       Enhancing objects         Moving objects  



To group objects 
1 Select all the objects you want to group.    
2 From the Draw menu, choose Group. 

--Or--
Press CTRL+G.    
Four resize handles are displayed around all objects to show that the objects are grouped.    
Grouped objects remain associated until you ungroup them, unlike objects in a multiple selection which lose 
their association when you cancel their selection. 

You can nest groups so that groups can be individual members of larger groups.    
You can change the attributes of all objects in a group, but you cannot edit the attributes of an individual 

object in a group.    For example, you cannot change the fill pattern of one object in a group without changing the fill
pattern of all of the objects in the group that are filled.    



To ungroup a set of grouped objects 
1 Select the group you want to ungroup.    

When you select one member of a group, the entire group is selected.    
2 From the Draw menu, choose Ungroup.

--Or--
Press CTRL+H.    
The constituents of the group become individually selected.    

Grouped objects are brought together in their current stacking order.    When you ungroup a group, the original
stacking order may not be reinstated.    
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Overview

You can change objects you have drawn by cutting, copying, pasting, or clearing them.    You edit objects using 
commands on the Edit menu. 

 

How To
       Cut objects         Copy objects  
       Paste objects         Clear objects  

Related information
       Enhancing objects  
       Undoing Microsoft Draw operations   



To cut one or more objects from your drawing
1 Select the object or objects you want to cut.    
2 From the Edit menu, choose Cut.

--Or--
Press SHIFT+DEL.    
The object is deleted from your drawing and a copy is placed on the Clipboard, replacing whatever was already
there.
You can paste deleted objects by choosing the Paste command on the Edit menu or by pressing SHIFT+INS.    



To copy one or more objects from your drawing
1 Select the object or objects you want to copy.    
2 From the Edit menu, choose Copy. 

--Or--
 Press CTRL+INS.    
A copy of the object is placed on the Clipboard so you can paste it to a new location.



To paste from the Clipboard
1 From the Edit menu, choose Paste. 

--Or--
Press SHIFT+INS. 
The contents of the Clipboard are placed into your drawing as one or more objects which remain selected so 
that you can move, resize, or edit them.    

2 To paste another copy, choose Paste again.    

If the Clipboard is empty (that is, if nothing has been cut or copied), or if the format of the Clipboard 
contents is not supported, the Paste command is unavailable.    

You can only paste text from the Clipboard into a text object that you are currently editing.



To clear one or more objects
1 Select the object or objects you want to clear.    
2 From the Edit menu, choose Clear. 

--Or--
Press DEL. 
The object is deleted from your drawing.

If you clear an object by mistake, immediately choose Undo from the Edit menu to restore the cleared object.    
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Overview

You can change the location of an object in your drawing by moving it.    Microsoft Draw lets you move objects in 
several ways: by dragging, changing their stacking order, rotating, or flipping them.    

How To
       Drag objects         Change the stacking order  
       Rotate objects         Flip objects  

Related information
       Selecting objects         Editing objects  
       Working with bitmaps  



To move a single object
1 Position the pointer over any drawn part of the object.    
2 Drag the object to a new location.    

Notice that dragging the object also selects it.    

To move several objects or to move a grouped object
1 Select all objects to be moved or select a group to be moved.    
2 Position the pointer over a drawn part of any one of the selected objects and drag the objects to a new location.  

If you start to drag slowly, you'll see ghosts of the objects move.    If you start to drag quickly, you'll see only a 
bounding box move.    

To constrain movement to a horizontal direction, hold down the SHIFT key as you drag the object to the 
right or left.    

To constrain movement to a vertical direction, hold down the SHIFT key as you drag the object up or down.   



To bring one or more objects to the front of all other objects in a drawing 
1 Select one or more objects to bring to the front.    
2 From the Edit menu, choose Bring To Front.

--Or--
Press CTRL+ = (equal sign).    

The object or objects are moved to the front.    

To send one or more objects to the back of all other objects in a drawing 
1 Select one or more objects to send to the back.    
2 From the Edit menu, choose Send To Back.

--Or--
Press CTRL+ - (minus sign).    

The object or objects are sent to the back.    

Each new object you draw is displayed on its own layer and, therefore, can be stacked on top of other objects so 
that they overlap.
Note that if you change the stacking order of several objects at once, the original order of the objects with 
respect to one another is preserved.    



To rotate an object or a group
1 Select the object or group.    
2 From the Draw menu, choose Rotate/Flip to display the Rotate/Flip submenu.    
3 Choose Rotate Left or Rotate Right.    

The object or group of objects rotate.    

If a text object or a bitmap object is part of a group to be rotated, the object changes position relative 
to the center of the group but is not itself rotated.    

You can rotate an object or a group 90° right (clockwise) or 90° left (counterclockwise).    You must group 
objects in a multiple selection before you can rotate them.    



To flip an object or a group of objects
1 Select the object or group.    

2 In the Draw menu, choose Rotate/Flip to display the Rotate/Flip submenu. 
3 Choose Flip Horizontal or Flip Vertical.    

The object or group flips.    

If a text object or a bitmap object is part of a group, the object changes position relative to the center of
the group but is not itself flipped.    

You can flip an object or a group relative to its horizontal or vertical axis.    You must group objects in a 
multiple selection before you can flip them.    
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Overview

Microsoft Draw provides several techniques for adding and changing the line, fill, pattern, and other attributes of 
objects.    

Related information
       Using color  
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Drawing framed and unframed objects

You can draw objects (except for lines, bitmap objects, and text objects) with or without frames, and you can 
change a previously drawn object from framed to unframed and vice versa.    Whether or not an object is framed 
when you first draw it depends on the default setting of the Framed command on the Draw menu.The line style 
and color of the frame depend on settings in the Line Style submenu and Color Palette.    

How to
       Change the default framing option  
       Change an object's frame attribute  
       Change an object’s frame color  

Related information
       Using color  



To change the default framing option
1 Click the Arrow tool to make sure that no objects are selected.    
2 From the Draw menu, choose Framed.    

The diamond next to the command is no longer displayed, indicating it is no longer set to framed.    
3 To change the default from unframed to framed, choose Framed from the Draw menu again.    

The diamond is displayed next to the command, indicating that it is now set to framed.    



To change an object's frame attribute
1 Select the object or objects whose frame attribute you want to change.    
2 From the Draw menu, choose Framed.    

A check mark is displayed next to the command, if the object is already framed (or if all of the objects in a 
multiple selection are framed).    Choosing the command again unframes everything in the selection and 
removes the check mark to indicate that the selection is no longer framed.    
If the object is not framed (or if some of the objects in a multiple selection are not framed), there is no check 
mark next to the command.    Choosing the command frames everything in the selection that can be framed and
places a check mark next to the option to indicate that the selection is framed.    



To change an object's frame color
1 Select one or more framed objects.    
2 If the Color Palette is not already showing, choose Show Palette from the Colors menu.    
3 In the Color Palette, click a line color for the frame.    

The new color is applied only to objects that are already framed.    

Note that if an object has a pattern, the color is applied to the foreground of the pattern as well. 
If none of the objects in the selection are framed, then any object that can be framed is framed in the 

selected color.    
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Drawing filled and unfilled objects

You can draw objects with filled interiors or with unfilled interiors and you can change a previously drawn object 
from filled to unfilled and vice versa.    Whether or not an object is filled when you first draw it depends on the 
default setting of the Filled command on the Draw menu.    When you fill an open freeform, it appears closed. The 
pattern and color of the fill depend on settings in the Pattern submenu and the Color Palette.    

How to
       Change the default fill option  
       Change an object's fill attribute  
       Change an object’s fill color  

Related information
       Using color  



To change the default fill option
1 Click the Arrow tool to make sure that no objects are selected.    
2 From the Draw menu, choose Filled.    

The diamond next to the command is no longer displayed, indicating it is no longer set to filled.    
3 To change the default from unfilled to filled, choose Filled from the Draw menu again.    

The diamond is displayed next to the command, indicating that it is now set to filled.    



To change an object's fill attribute
1 Select the object or objects whose fill attribute you want to change.    
2 From the Draw menu, choose Filled.    

A check mark is displayed next to the command if the object is already filled (or if all of the objects in a 
multiple selection are filled).    Choosing the command again unfills everything in the selection that can be 
filled and removes the check mark to indicate that the selection is no longer filled.    
If the object is not filled (or if some of the objects in a multiple selection are not filled), there is no check mark 
next to the command.    Choosing the command fills everything in the selection and places a check mark next to 
the command to indicate that the selection is filled.    



To change an object's fill color
1 Select one or more filled objects.    
2 If the Color Palette is not already displayed, choose Show Palette from the Colors menu.    
3 In the Color Palette, click a fill color. 

 
The new color is applied only to objects that are already filled.    

Note that if an object has a pattern, the color is applied to the background of the pattern.    
If none of the objects in the selection are filled, then any object that can be filled is filled with the selected 

color.    
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Patterns

You can give any object one of seven patterns chosen from the Pattern submenu on the Draw menu, (with the 
exception of lines, bitmap objects, and text objects):

How to
       Change the default pattern  
       Change an object's pattern  

Related information
       Using Microsoft Draw's Toolbox  
       Undoing Microsoft Draw operations  
       Using color  



To change the default pattern
1 Click the Arrow tool to make sure that no objects are selected.    
2 From the Draw menu, choose Pattern. 

The Pattern submenu is displayed.
3 From the submenu, choose a new default pattern.    

 
A diamond is displayed next to the chosen pattern and any new object you draw will have the new default 
pattern.    



To change an object's pattern
1 Select the object or objects whose pattern you want to change.    
2 From the Draw menu, choose Pattern.    

The Pattern submenu is displayed.
3 From the submenu, choose a pattern.    

A check mark is displayed next to the chosen pattern and the chosen pattern is applied to everything in the 
selection, except bitmap objects, text objects, and lines.    
The new pattern is applied only to those objects that already are filled.    
If none of the selected objects have a pattern or are filled with a solid color, then any object that can have a 
pattern becomes filled with the pattern.    

You can apply a foreground color and a background color to any of the six hatch patterns.    The foreground 
color is the same as the line color and the background color is the same as the fill color selected on the Color 
Palette.    Dithered colors are displayed as the nearest solid color, for example, patterns given a very dark dithered
color are displayed as black.

You cannot scale patterns. For an accurate view of how a pattern will print, use the Zoom In/Zoom Out tool 
or the Full Size command on the View menu to view the object at full scale.    

If you import a drawing that was not created in Microsoft Draw, it may contain patterns not available in the
Pattern submenu.    If you change one of these patterns and do not immediately undo the change, the original 
pattern will be lost.    Patterns in imported drawings are displayed in their original fill colors. 
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Line style

The Line Style submenu of the Draw menu gives you several line styles to apply to straight lines and to frames 
around ellipses, rectangles, and other shapes.    You can draw dashed lines, hairlines, and lines in any of six 
standard widths.    You can also customize the width of a line.    

How to
       Change the line style default  
       Change an object's line style  
       Customize line width  

Related information
       Using color  



To change the line style default
1 Click the Arrow tool to make sure that no objects are selected.    
2 From the Draw menu, choose Line Style.    

The Line Style submenu is displayed.    
3 From the submenu, choose a default line style.    

A diamond is displayed next to the chosen line style as the submenu closes.    Any new line or frame you draw 
will have the new default line style.    
A line or frame can have only one style at a time.    You cannot mix styles.    For example, you cannot create a 
four-point dashed line.    
The line color will be the same as the line color selected on the Color Palette.    



To change an object's line style
1 Select the object or objects whose line style you want to change.    
2 From the Draw menu, choose Line Style to display the Line Style submenu.    
3 From the submenu, choose a line style.    

 
A check mark is displayed next to the chosen line style. 
The chosen line style is applied only to those objects that already have a line style.    
If none of the objects have a line style, then any object that can have a line style is given one.    



To customize line width 
1 Select the object or objects whose line width you want to change.    
2 From the Draw menu, choose Line Style to display the Line Style submenu.    
3 From the Line Style submenu, choose Other. 

The Other Size dialog box is displayed.    
4 Type a number of points (whole numbers only, not fractions) in the Size field and click the OK button.    

 
The dialog box closes and the line width is applied to the selection.    

To determine the width of a customized line or frame
1 Select the object whose width you want to determine.    
2 Choose Line Style from the Draw menu to display the Line Style submenu.    
3 From the Line Style submenu, choose Other.    

The Other Size dialog box is displayed.    

The number in the Size field shows the line width of the selected object.    
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Changing the size and shape of objects

Microsoft Draw gives you several ways to change an object's size by stretching or squeezing. 

How to
       Resize objects  

Related information
       Editing objects  
       Selecting objects  



To resize an object or a set of grouped objects
1 Select the object or group.    
2 Drag a resize handle until the ghost outline of the selection is the desired size.    

3 Release the mouse button.    
The object is the desired size.    

To maintain the angle of a line, hold down the SHIFT key as you resize the line.    
To maintain the width of an object as you resize the height, hold down the SHIFT key as you drag vertically.   
To maintain the height of an object as you resize the width, hold down the SHIFT key as you drag 

horizontally.    
To maintain the overall proportion of an object as you resize, hold down the SHIFT key as you drag 

diagonally.    
To shrink or enlarge an object around its center point, hold down the CTRL key as you drag.    
To shrink or enlarge an object around its center point as you constrain the object to the horizontal, vertical,

or to the object's original proportions, hold down SHIFT+CTRL as you drag.    
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Working with bitmaps

A bitmap object is an object represented as an array of pixels or dots, rather than as a set of instructions for 
drawing the object as are other Microsoft Draw objects.    

Microsoft Draw lets you import bitmaps and edit them as you would a single object.    You can move a bitmap by 
dragging it, or you can resize a bitmap by dragging its resize handles (pressing SHIFT while double-clicking the 
bitmap restores it to its original size).    You can change the color of a one- or two-color bitmap, the Color palette's 
line color is applied to the bitmap's foreground, and the fill color is applied to the bitmap's background.    You can 
also add colors from a two-color bitmap to the Color Palette.    

Note that if a bitmap object is part of a group to be rotated or flipped, the object changes position relative to the 
center of the group but is not itself rotated or flipped.    

Related information
       Moving objects  
       Using color  
       Enhancing objects  
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Using the grid

With Microsoft Draw, you can use an invisible grid to align and place objects with precision.    There are 12 grid lines 
per inch.    

The grid may be on or off.    When the grid is on you cannot see it, but any objects or groups that you create, move, 
or resize will snap to the nearest grid intersection.    

To turn on the grid, choose Snap To Grid from the Draw menu.    A check mark is displayed next to the option to 
indicate that it is on.    Choosing Snap To Grid does not affect the position of existing objects unless you move them. 
To turn the grid off, choose Snap To Grid again.    The check mark is no longer displayed.    

Related information
       Using guides  
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Using guides

With Microsoft Draw, you can use a horizontal or vertical guide as a straightedge to align and place objects 
precisely.    When an object’s edge or center gets close to a guide, that edge or center will automatically snap to 
the guide.    As you drag a guide, a readout tells you the distance from the top left corner of the drawing area, so 
you can use the guide to place objects at precise distances from any point.    

How to
       Use guides  

Related information
       Using the grid  



To use guides
1 From the Draw menu, choose Show Guides.

--Or--
Press CTRL+W. 
A check mark is displayed next to the command to indicate that the guides are on.    The guides are displayed at 
the center of the screen.    

2 Drag the guides to the desired location.    
The center or edge of any object moved near the guide will snap to it.    
To hide the guides, choose Show Guides from the Draw menu or press CTRL+W again.    The check mark is no 
longer displayed next to the command.    
To use a guide to measure the distance from an arbitrary starting point, hold down CTRL as you drag the guide.    
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Updating a drawing

When you update a drawing you save the current version of the drawing in the destination application without 
exiting Microsoft Draw.    

How to
       Update a drawing  

Related information
       File menu  



To update a drawing
From the File menu, choose Update.    
If the Update command is unavailable, it means that the destination application does not support updating 
and you must update the drawing by choosing Exit And Return from the File menu.    
You cannot undo an update from within Microsoft Draw.    
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Importing files into Microsoft Draw

You can import files into Microsoft Draw that were created in other graphics applications.    Once you import a file, 
you can edit it with Microsoft Draw tools.    

How to
       Import a file  

Related information
       Selecting objects         Moving objects  
       Working with bitmaps  



To import a file
1 From the File menu, choose Import Picture.    

A dialog box is displayed.    
2 In the Directories list, select the drive and/or directory that contains the file you want to import.    

3 In the Files list box, select the name of the file you want to import.    Note that the Files list box displays only 
those files that you can import. 

4 Choose OK.    
The objects in the file are "disassembled" and pasted into Microsoft Draw as a multiple selection.    The 
manner in which the imported file is disassembled depends on the nature of the objects and on the application 
in which they were created.      
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Overview

Microsoft Draw offers several useful techniques for adding and changing drawing color.    
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The Color Palette

Microsoft Draw includes a Color Palette with two kinds of color: line color and fill color.    Use line color for lines, 
frames, pattern foreground, and text.    Use fill color for shape interiors and pattern background.    You can have up 
to 100 line colors and 100 fill colors in a palette.    

To show the Color Palette, choose Show Palette from the Colors menu.    To hide the palette, choose Show Palette 
again.    

How to
       Set a new default color  
       Change an object's color  
       Edit a color palette  
       Get a color palette  
       Save a color palette  



To set a new default color
1 Click the Arrow tool to make sure that no objects are selected.    
2 In the Color Palette, click the line color or fill color that you want to be the default color. 

 
A diamond is displayed on the color swatch as the new default is set.    

To set another color as a default color
1 Make sure no object is selected.
2 Click Other.

The Color Picker is displayed. 
3 From the Color Picker, select a color.
4 Click OK. 

A swatch of the selected color is displayed in the Other box on the Color Palette. 



To change the line color or fill color of an object
1 Select one or more objects.    
2 In the Color Palette, click the color that you want applied to the selection.

A check mark is displayed on the chosen color in the palette, as the color of the selection changes.    
To bring the color swatch of a selected object into view on the palette, click Line or Fill on the palette.    

If more than one object is selected, selecting a color changes the color of only those objects that have a 
corresponding attribute (for example, line color affects only framed, patterned, or text objects.)    If no objects in 
the selection have a corresponding attribute, selecting a color gives them the attribute (for example, selecting a fill 
color fills an unfilled rectangle).    

Microsoft Draw may not support all colors that the destination application supports.    Microsoft Draw 
shows an unsupported color as a dithered color.    The color is displayed appropriately upon return to the 
destination application.    



To edit a palette
1 From the Colors menu, choose Edit Palette.

The Edit Palette dialog box is displayed.    
2 You can change, add, and delete colors from the existing palette using this dialog box.    

Note that editing a palette does not affect the existing colors in a drawing.    

To change a color on the Color Palette 
1 Click the color you want to change.
2 Choose Change.

--Or-- 
Double-click the color.    
The Color Picker dialog box is displayed and you can use it to change the color.    

3 To add a new color to the palette, click Add.
--Or--
Double-click an empty color square.    
The Color Picker dialog box is displayed and you can use it to add the new color.    

4 To delete a color, click the color you want to delete and then choose Delete.    

To re-organize the colors in the palette, drag a color to a new location. 



To get a saved Microsoft Draw palette
1 From the Colors menu, choose Get Palette.    

A dialog box is displayed.    
2 In the Directories list, choose the drive and/or directory that contains the palette file you want.    

3 In the Files list box, select the name of the palette file you want to get.    
4 Click OK.    

The palette is loaded into Microsoft Draw, replacing your previous palette but leaving the existing colors in your 
drawing unchanged. 

You can also use this procedure to get a saved Paintbrush palette to use in Microsoft Draw.



To save a palette
1 From the Color menu, choose Save Palette.    

A dialog box is displayed.    
2 In the Directories list, choose the drive and/or directory to which you want to save the palette file.    

3 In the Save Palette As box, type the name you want to give the palette file.    
4 Click OK.    

The palette is saved with a .PAL extension.    

You can save a palette to use with Microsoft Paintbrush if the palette contains no more than 28 colors. 
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Using the Color Picker

Use the Color Picker to edit or create new palette colors.    Display the Color Picker dialog box with any of these 
methods: 

Click Other on the palette for either line or fill color.    

In the Edit Palette dialog box, select a color and click Change, or double-click the color you want to change.    

In the Edit Palette dialog box, click Add or double-click an empty square.    

How to
       Define a new color  



To define a new color and place it in the current palette
1 Edit or create the color using any of these techniques alone or in combination:
2 In the Color refiner box, drag the color refiner cursor to the area that shows the color you want.    

3 In the luminosity bar, drag the arrow up or down to adjust the luminosity of the color.    

4 In the Red/Green/Blue or Hue/Sat/Lum text boxes, enter values.    

You can type the values into the boxes or click the scroll arrows to the right of the text box to increase or 
decrease the value.    
As you change the color, the new color is displayed on the left side of the Color/Solid box.    The right side of the 
box displays the solid color closest to your choice.    A solid color is a color directly supported by your display.    
Non-supported colors are produced by a dithered color.    If you want to select the solid color, click the right 
side of the box.    
Note that when luminosity is set to 0, all colors are displayed as black. When luminosity is set to 240, all colors 
are displayed as white. 

5 When you are satisfied with the color, click OK.    
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Overview

In Microsoft Draw, a text object is a single line of text.    Microsoft Draw gives you several techniques for using and 
modifying text objects in your drawings.    

How to
       Create new text         Edit text characters  
       Change text style         Change text alignment  
       Change text font         Change text size  

Related information
       Undoing Microsoft Draw operations  
       Editing objects  



To create a new text object
1 Make sure the current settings for font, font size, font style, alignment, and text color are appropriate for the text

you want to type.    You can change them later if you wish.    
2 In the Toolbox, click the Text tool.    
3 Click where you want the text to start.    

A text insertion point is displayed.    
4 Enter the text.    You can type only a single line of text.    

Use the BACKSPACE key, mouse, or arrow keys to correct typing.    
Press CTRL+INS to copy selected characters to the Clipboard.    
Press SHIFT+INS to paste characters from the Clipboard into the text object.    
Press SHIFT+DEL to cut selected characters and place them on the Clipboard.    

5 When you are satisfied with the text, press ENTER, ESC, or click outside the text object.    
Resize handles are displayed around the new text object.    
Note that you can only paste text from the Clipboard into a text object that you are currently creating or editing. 



To edit a text object
1 Select the text object you want to edit.    
2 From the Edit menu, choose Edit Text, or double-click the text object.    

A text insertion point is displayed.    
3 Edit the text.    You can type only a single line of text.    

Use the BACKSPACE key, mouse, or arrow keys to correct typing.    
Press CTRL+INS to copy selected characters to the Clipboard.    
Press SHIFT+INS to paste characters from the Clipboard into the text object.    
Press SHIFT+DEL to cut selected characters and place them on the Clipboard.    

4 When you are satisfied with the text, press ENTER, ESC, or click outside the text object.    
The edited text replaces the original text object.    



To change the text style (Plain, Bold, Italic, Underline)
1 Select the text object you want to change.    
2 From the Text menu, choose the desired style.    

The new text style is applied.    
Note that bold, italic, and underline styles may be used in combination.    The plain style turns off the other three
styles.    

To change to a new text style default 
1 Make sure that no objects are selected.    
2 From the Text menu, choose the desired style or styles.    



To change the text alignment (left, center, right)
1 Select the text object you want to change.    
2 From the Text menu, choose the desired alignment.    

The new text alignment is applied.    
Note that alignment affects the direction in which the text "grows" as it is edited.    Left alignment grows to the 
right.    Right alignment grows to the left.    Center alignment grows in both directions.    If you change the 
alignment of a completed text object, you won't notice any difference until you edit the object.    

To change to a new text alignment default 
1 Make sure that no objects are selected.    
2 From the Text menu, choose the desired alignment.    



To change the text font
1 Select the text object you want to change.    
2 From the Text menu, choose Font.    

The Font submenu is displayed.    
3 From the Font submenu, choose the desired font. 

The new text font is applied.    

To change to a new text font default 
1 Make sure that no objects are selected.    
2 From the Text menu, choose Font.    

The Font submenu is displayed.    
3 From the Font submenu, choose the desired font. 

 
Note that pasted text that was not created in Microsoft Draw may use fonts that are not available in the current 
Font submenu.    If you change the font and do not immediately undo the change, the original font will be lost.    
Also note that if you change the font for rotated text in an imported drawing, that text will become unrotated. 



To change the text size
1 Select the text object you want to change.    
2 From the Text menu, choose Size.    

The Size submenu is displayed.    
3 From the Size submenu, choose the desired text size.    

The new text size is applied.    

To change text to a size that is not displayed in the Size submenu
1 From the Size submenu, choose Other. 

The Other Size dialog box is displayed.    
2 In the Size field, type the font size you want

3 Choose the OK button.    
The dialog box closes and the size is applied to the selection.    
Note that you cannot resize text by dragging resize handles.    

To change to a new text size default 
1 Make sure that no objects are selected.    
2 From the Text menu, choose Size.    

The Size submenu is displayed.    
3 From the Size submenu, choose the desired size.

--Or-- 
Choose Other and type the desired font size in the Size field.    



Undoing Microsoft Draw operations  1 of 1 

Undoing Microsoft Draw operations

To cancel your last drawing command, choose Undo from the Edit menu.    

You can undo an update to the destination application only if the destination application supports undoing an 
update.    

Note that you cannot undo changes to the Color Palette.    

Related information
       Edit menu  
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Exiting Microsoft Draw

Return to the destination application by choosing Exit And Return from the File menu.    If you choose Exit And 
Return and the drawing has been modified since the last update or since the last Exit And Return, you are asked 
whether or not you want to update your destination document or cancel.    

When you return to the destination application, any changes or new drawings you created become part of the 
destination document and can be edited as the destination application tools allow.    

Related information
       File menu  
       Updating a drawing   
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Overview

Choose commands from Microsoft Draw menus as you would any Windows application commands.    To select a 
menu from the keyboard, hold down the ALT key as you press the underlined character in the menu name.

To choose an item from a selected menu, press the underlined character in the item.    Keyboard shortcuts are 
displayed on the right side of each menu.
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File menu

To select the File menu from the keyboard, press ALT+F. To choose an item from the File menu, press the underlined 
character in the item.    

How to
       Update:   Update drawing in destination application
       Import Picture:   Import graphics file
       Exit and Return:   Exit and return to destination application
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Edit menu

To select the Edit menu from the keyboard, press ALT+E. To choose an item from the Edit menu, press the underlined
character in the item.

more...
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Edit menu, cont.

Other Edit menu keyboard shortcuts are displayed on the right side of the Edit menu.

How to
       Undo:      Cancel last operation.
       Cut:    Move to Clipboard.
       Copy:      Put copy of selection on Clipboard.
       Paste:      Put Clipboard contents on drawing.
       Clear:      Delete selection.
       Select All:      Select all objects.
       Bring to Front:      Move selected objects in front of all others.
       Send to Back:      Move selected objects behind all others.
       Edit (text) object:      Edit text characters.
       Edit (freeform or arc) object:      Edit freeform or arc.
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View menu

To select the View menu from the keyboard, press ALT+V. To choose an item from the View menu, press the 
underlined character in the item.    

How to
       25%, 50%, 75% Size:   Reduce drawing view (zoom out).
       Full Size:      Show drawing at actual size.
       200%,400%, 800% Size:      Magnify drawing view (zoom in).
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Text menu

To select the Text menu from the keyboard, press ALT+T. To choose an item from the Text menu, press the 
underlined character in the item.

more...
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Text menu, cont.

Other Text menu keyboard shortcuts are displayed on the right side of the Text menu.    

How to
       Plain:      Set text style to plain (turn off other styles).
       Bold:      Set text style to bold.
       Italic:      Set text style to italic.
       Underline:      Set text style to underline.
       Left:      Align text left.
       Center:      Center text.
       Right:      Align text right. 
       Font:      Change text font.
       Size:      Change text size.
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Draw menu

To select the Draw menu from the keyboard, press ALT+D. To choose an item from the Draw menu, press the 
underlined character in the item.

more...
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Draw menu, cont.

Other Draw menu keyboard shortcuts are displayed on the right side of the Draw menu.

How to
       Group:      Group selected objects.
       Ungroup:      Ungroup selected group.
       Framed:      Draw outline around object.
       Filled:      Fill interior of object.
       Pattern:      Select one of seven fill patterns.
       Line Style:      Select a style for line type or width.
       Snap to Grid:      Snap objects to nearest grid point.
       Show Guides:      Show horizontal and vertical guides.
       Rotate/Flip:      Rotate or flip selected object.
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Colors menu

To select the Colors menu from the keyboard, press ALT+C. To choose an item from the Colors menu, press the 
underlined character in the item.    Other Colors menu keyboard shortcuts are displayed on the right side of the 
Colors menu.    

How to
       Show Palette:      Display Color Palette at bottom of drawing area.
       Edit Palette:      Change, add, or delete colors from palette.
       Add Colors from Selection:      Add colors of selected object to palette.
       Get Palette:      Select and open an existing palette.
       Save Palette:      Save current palette.



To undo an operation
From the Edit menu, choose Undo.    
You can undo an update to the destination application only if the destination application supports undoing an 
update.    
Note that you cannot undo changes to the Color Palette.    



To exit Microsoft Draw
From the File menu, choose Exit And Return.    
If you choose Exit And Return and the drawing has been modified since the last update or since the last Exit And 
Return, you are asked whether or not    you want to update your destination document or cancel.    

When you return to the destination application, any changes or new drawings you created become part of the 
destination document and can be edited as the destination application tools allow.    



To add colors from a selection
If individual objects have edited colors, choosing this option from the Colors menu adds the color from the 
selected object to the existing Color Palette.



To use the grid
1 To turn on the grid, choose Snap To Grid from the Draw menu. 

A check mark next to the option to indicates that it is turned on. 
Choosing Snap To Grid does not affect the position of existing objects unless you move them.    
When the grid is on you cannot to see it, but any objects or groups that you create, move, or resize will snap to 
the nearest grid intersection.    Use the invisible grid to align and place objects with precision.    

2 To turn the grid off, choose Snap To Grid again.    The check mark is no longer displayed.    



To display the Color Palette
From the Colors menu, choose Show Palette.    
The palette is displayed at the bottom of the drawing area.
To hide the palette, choose Show Palette again.



Bitmap object
An object represented as an array of pixels or dots, rather than as a set of instructions for drawing the object.    
Microsoft Draw lets you import bitmaps by way of the Clipboard and the Import Picture command on the File menu.



Bounding box
The dotted outline of a rectangle drawn around one or more objects to mark them as chosen. This is one way to 
create a multiple selection.    When an object is selected, resize handles are displayed at the corners.



Destination application
The application from which you invoke Microsoft Draw to create a drawing.    When you exit Microsoft Draw, the 
drawing you created is embedded into the destination application document.    



Clipboard
A temporary storage area for cut or copied graphics or text.    You can paste the Clipboard contents into a Windows 
application that supports the format of the cut or copied material.    



Control handles
Handles displayed as small black squares at the vertices of freeform figures and at the ends of arcs.    Drag control 
handles to edit the shape of these figures.    Control handles are different from resize handles, which you use to 
change the size of objects.    



Default
A standard value for a specific object attribute.    For example, if the default line style is set to 2 points, any line you 
draw will be two points wide.    You can reset defaults as you wish.    When you exit Microsoft Draw, the current 
defaults are preserved.    



Dithered color
A pattern of colored dots that simulates a solid color.    



Hairline
The thinnest line your display or printer device can produce.    Hairlines remain thin at all magnification views and 
are always displayed as the nearest solid color.



Multiple selection
Two or more objects that are selected with their resize handles displayed at the same time.    Multiple selections 
may contain grouped objects but the entire multiple selection is not itself a group.



Freeforms
Any of several figures drawn with the Freeform tool.    Freeform figures include polygon freeforms, freehand 
freeforms, or combination freeforms.    



Resize handles
Handles displayed as small black squares at the corners of an imaginary box around selected objects, and at the 
beginning and ends of selected lines.    

To change the size of a selected object, drag one of its resize handles to the desired shape.    Resize handles are 
different from control handles, which are used to edit freeform figures and arcs.    



Snap to
To be attracted to.    For example, objects moved close to a guide will snap to the guide.    



Stacking order
The order in which objects are layered in a drawing.    Objects may be in front of or behind other objects.    You can 
change the stacking order of objects with the Bring To Front and Send To Back commands on the Edit menu.    



Text object
A single line of text created with the Text tool.    You can give a text object a line color, but not a fill color.    You can 
move a text object, but you cannot flip or rotate it.    You cannot resize a text object with its resize handles.    



Vertex, vertices
The end point or beginning point of a segment of a freeform figure.    When editing these figures, control handles 
appear at each vertex.    Dragging a control handle moves the point to a new location and changes the object's 
shape.    






